[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: setprop vs. propset

From: Stefan Sperling <stsp_at_elego.de>
Date: Sat, 23 Aug 2008 14:56:30 +0200

On Sat, Aug 23, 2008 at 10:05:26AM +0200, Jens Seidel wrote:
> On Fri, Aug 22, 2008 at 07:05:18PM -0500, Peter Samuelson wrote:
> > [Tyler Winter Mace]
> > > I have trouble using the "propset" and "propget" (etc) commands. Almost
> > > every time, I type "setprop" or "getprop." That's because I want to "set"
> > > a "property" and that's how I expect the command to be when I type it on
> > > the command line.
> >
> > Probably the simplest thing is just to get used to the abbreviations
> > pl, pg, ps, pe, pd. If you think of a group of 5 two-letter commands
> > with a common one-letter prefix, it should be easy to remember it isn't
> > a common one-letter suffix. Or maybe it's just me. As Jay Ashworth
> > says, so many things are just me.
> Oh, yes, it's just you :-)

Note that there is a patch attached to the issue #3268 already:

It's trivial to add these aliases. I am perfectly fine with
adding them, and I'd like to commit the patch.

The patch adds all of the following aliases:

  delprop, delp, dp,
  editprop, editp, ep,
  getprop, getp, gp,
  listprop, listp, lp,
  setprop, setp, sp

The whole point of this thread should be that anyone who does not
want these aliases to be added for whatever reason please speak up now.

But please give a good reason. I personally can't come up with of any
other counter argument than "please let's not add more and more aliases
because we will end up with way too many of them, cluttering the UI."

And while I agree that adding too many aliases for commands can
lead to a confusing UI in the long term, I don't think that it
will cause confusion in this particular case.

"svn setprop" parses just as well as "svn propset", maybe even better
because setprop follows proper English word order more closely.

Adding these aliases makes the svn program easier to use.
Humans are notoriously bad at remembering little details such as the
order of two particular syllables which make up a command.
I wish my editor was as forgiving whenever I type ":set tabexpand"
instead of ":set expandtab" (or which way was it again? :)

For reference, here is what the relevant part of the 'svn help'
output looks like after applying the patch:

  Available subcommands:
     blame (praise, annotate, ann)
     changelist (cl)
     checkout (co)
     commit (ci)
     copy (cp)
     delete (del, remove, rm)
     diff (di)
     help (?, h)
     list (ls)
     move (mv, rename, ren)
     propdel (pdel, pd, delprop, delp, dp)
     propedit (pedit, pe, editprop, editp, ep)
     propget (pget, pg, getprop, getp, gp)
     proplist (plist, pl, listprop, listp, lp)
     propset (pset, ps, setprop, setp, sp)
     status (stat, st)
     switch (sw)
     update (up)
Note that the prop* commands are the only commands that logically
consist of two seperate words. So this is *not* a precedent of
adding more and more aliases to every command just for the sake of it.


To unsubscribe, e-mail: dev-unsubscribe_at_subversion.tigris.org
For additional commands, e-mail: dev-help_at_subversion.tigris.org
Received on 2008-08-23 14:55:59 CEST

This is an archived mail posted to the Subversion Dev mailing list.

This site is subject to the Apache Privacy Policy and the Apache Public Forum Archive Policy.