[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

[PATCH] use class to minimize duplicate code in kwallet.cpp

From: Martin Furter <mf_at_rola.ch>
Date: Fri, 20 Jun 2008 01:56:06 +0200 (CEST)

I can't test this patch since I do not have KDE4. But I compared it to the
old code and I believe it does the same things.

Move the kwallet_password_get/kwallet_password_set code of
libsvn_auth_kwallet into a class to minimize duplicated code.

* subversion/libsvn_auth_kwallet/kwallet.cpp
   (SvnKWallet): New class containing the code of kwallet_password_get
     and kwallet_password_set.
   (kwallet_password_get): Use SvnKWallet to do the work.
   (kwallet_password_set): Ditto.

To unsubscribe, e-mail: dev-unsubscribe_at_subversion.tigris.org
For additional commands, e-mail: dev-help_at_subversion.tigris.org

Received on 2008-06-20 01:56:36 CEST

This is an archived mail posted to the Subversion Dev mailing list.

This site is subject to the Apache Privacy Policy and the Apache Public Forum Archive Policy.