[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: "svn cleanup" doesn't; advice needed

From: Branko ─îibej <brane_at_xbc.nu>
Date: Thu, 05 Jun 2008 22:57:02 +0200

Karl Fogel wrote:
> Eric Hanchrow <offby1_at_blarg.net> writes:
>
>> So somehow I got a wedged wc -- I probably killed a "svn up" process.
>> No problem, thinks I; I'll just run "svn cleanup".
>>
>> [...]
>>
>> So: I've got a locked wc, but "svn cleanup" won't unlock it. What's the
>> deal? I cannot reliably reproduce this, so I hesitate to enter an issue
>> in the issue tracker.
>>
>
> I've heard other reports of this on users@. But you're right, without a
> repro recipe, it's hard to do anything.
>
> As an aside, we should deprecate the "L" char and the "locked"
> terminology, because it's incredibly confusing to users: they think it's
> referring to our "locking" feature, which is, of course, totally
> unrelated to this.
>

Hmmm, we could use "F" instead, it sounds remarkably similar to "locked"
so the transition should be easy.

-- Brane

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe_at_subversion.tigris.org
For additional commands, e-mail: dev-help_at_subversion.tigris.org
Received on 2008-06-05 22:58:03 CEST

This is an archived mail posted to the Subversion Dev mailing list.

This site is subject to the Apache Privacy Policy and the Apache Public Forum Archive Policy.