[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Error in creating RPM for Subversion.

From: <Sanjeev-3.Kumar-3_at_cognizant.com>
Date: Thu, 15 May 2008 18:01:15 +0530

Hi.


I am trying to create a RPM for my subversion in fedora-8. I have
downloaded the latest source code in form of "subversion-1.4.6.tar".Now
for creating the RPM I am following the steps given inside the README
file for RPM generation inside
"D:\subversion-1.4.6\packages\rpm\redhat-8+"

cd ../..;

svn update -r <RevisionNumber>

cd packages/rpm/<distribution>; make



After doing this I am getting following errors:


Failed build dependencies:

        docbook-style-xsl >= 1.58.1 is needed by subversion-1.4.6-9.i386

        apr-devel >= 0.9.7 is needed by subversion-1.4.6-9.i386

        apr-util-devel >= 0.9.7 is needed by subversion-1.4.6-9.i386

        neon-devel >= 0.24.7 is needed by subversion-1.4.6-9.i386

        httpd-devel >= 2.0.48-0.1 is needed by subversion-1.4.6-9.i386

make: *** [build_rpm_files] Error 1




Please suggest what to do to remove this error and create the RPM
successfully.


Thanks

Sanjeev

This e-mail and any files transmitted with it are for the sole use of the intended recipient(s) and may contain confidential and privileged information.
If you are not the intended recipient, please contact the sender by reply e-mail and destroy all copies of the original message.
Any unauthorized review, use, disclosure, dissemination, forwarding, printing or copying of this email or any action taken in reliance on this e-mail is strictly
prohibited and may be unlawful.

  Visit us at http://www.cognizant.com
Received on 2008-05-15 15:03:53 CEST

This is an archived mail posted to the Subversion Dev mailing list.