[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: kwallet branch is finished

From: Arfrever Frehtes Taifersar Arahesis <arfrever.fta_at_gmail.com>
Date: Wed, 14 May 2008 20:26:50 +0200

2008-05-14 20:14 Stefan Sperling <stsp_at_elego.de> napisał(a):
> On Wed, May 14, 2008 at 08:21:51PM +0300, Daniel Shahaf wrote:
>> Arfrever Frehtes Taifersar Arahesis wrote on Wed, 14 May 2008 at 16:10 +0200:
>> > 2008-05-13 21:46 Daniel Shahaf <d.s_at_daniel.shahaf.co.il> napisał(a):
>> > > Has anybody except you used the branch or reviewed it?
>> >
>> > The really new code is enabled only when the '--with-kwallet' option
>> > is passed to `configure`. In other places I only made relatively small
>> > non-functional changes (e.g. I renamed 2 private functions etc.).
>> >
>> > Did my answer dispel your fears?
>> >
>>
>> Your answer did not answer my question, which sought to estimate not the
>> amount of code changes in the branch but the amount of human attention
>> it has received.
>
> I would like to test the branch, but given that is needs KDE4,
> and KDE4 on FreeBSD is still very much work in progress
> (http://wiki.freebsd.org/KDE4) testing this seems to require
> quite some effort.
>
> Does anyone of us run a system where KDE4 is easy to install?
>
> Arfrever, where did you get your KDE4 from?

KDE 4 is available in Gentoo.
http://www.gentoo.org/proj/en/desktop/kde/kde4.xml

> Does the kwallet branch need a lot of KDE4 to
> compile/run or just some libraries and the kwallet
> prgram?

Only kdelibs is directly needed (KWallet::Wallet is
defined in libkdeui.so.5 which belongs to kdelibs).
But to run KDE session some parts of kdebase are also needed.

> Could you compile a list of dependencies
> needed to install and test the kwallet branch?

qt-core
qt-dbus
qt-gui
kdelibs
Received on 2008-05-14 20:27:01 CEST

This is an archived mail posted to the Subversion Dev mailing list.