[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Segfault in Perl bindings, _wrap_apr_terminate when running "git svn rebase"

From: Dennis Schridde <devurandom_at_gmx.net>
Date: Tue, 13 May 2008 22:30:49 +0200

Am Dienstag, 13. Mai 2008 21:10:39 schrieb Eric Gillespie:
> =?UTF-8?B?QnJhbmtvIMSMaWJlag==?= <brane_at_xbc.nu> writes:
> > Dennis Schridde wrote:
> > > Surprise, surprise, Gentoo builds 1.4.6(-r2)
> > > without --enable-runtime-module-search, so that is why 1.4.6 works and
> > > 1.5.0_rc5 did not.
> >
> > IIRC that flag is new in 1.5, so that's not surprising. :)
> >
> > Thanks for the follow-up; and I think this could be a showstopper for
> > 1.5.
>
> No, the flag has only been renamed. I bet the bug exists in 1.4,
> as well. He even says that his 1.4 is not built with this flag.
>
> Dennis, can you rebuild 1.4.6 with --enable-dso (the 1.4 equivalent)
> and let us know if you get the same crash?
It does not seem to crash.

Though Gentoo has quite a bunch of additional flags and patches for 1.4.6:

http://sources.gentoo.org/viewcvs.py/gentoo-x86/dev-util/subversion/subversion-1.4.6-r2.ebuild?view=markup
${FILESDIR}:
http://sources.gentoo.org/viewcvs.py/gentoo-x86/dev-util/subversion/files/

If you like, I can maybe later try to compile it myself, and see if even
without the patches the bug is not present.

--Dennis

Received on 2008-05-13 22:52:33 CEST

This is an archived mail posted to the Subversion Dev mailing list.