[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

DIGEST-MD5 not working with svnserve/SASL

From: Eric Gillespie <epg_at_pretzelnet.org>
Date: Thu, 01 May 2008 11:06:10 -0700

[retitling the thread; not Windows-specific]

"Mark Phippard" <markphip_at_gmail.com> writes:

> I was wondering if DIGEST-MD5 was not working because it is not linked
> to OpenSSL? I noticed that the DLL you created was not either, but
> the SVN docs, imply this plugin supports encryption, and I recall the
> SASL docs saying it uses OpenSSL. So I wonder if the problem is that
> we do not have this DLL built using OpenSSL?

I don't think that's it, as I can now confirm that DIGEST-MD5
does not work with Linux client/server, either. We find this in
the log file:

May 1 10:50:06 svnfe-test svnserve[1696]: encoded packet size too big (809115648 > 4096)

That looks to me like an uninitialized or otherwise corrupted len
variable, or perhaps a char * with the wrong value, pointing to a
block of memory that has a null byte after 809115648 bytes ;->.

I don't know if it's related, but I made a change to
ra_svn/cyrus_auth.c in r29241, to fix a gssapi issue. It's
possible I broke something. It's also possible that more such
changes are needed.

--
Eric Gillespie <*> epg_at_pretzelnet.org

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe_at_subversion.tigris.org
For additional commands, e-mail: dev-help_at_subversion.tigris.org
Received on 2008-05-01 20:06:27 CEST

This is an archived mail posted to the Subversion Dev mailing list.