[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

svn switch breaks on svn:externals

From: Issac Goldstand <margol_at_beamartyr.net>
Date: Sun, 30 Mar 2008 16:06:47 +0300

Hi all,

After several weeks of trial and error, I *think* I may have discovered
a bug in 1.5 where svn:externals doesn't deal properly with peg URLs.
It gives an error where checkout and update don't.

See the following case:
--- START ---
cd /home/www/staging/staging.xxx.net ; /usr/local/bin/svn15 switch
--non-interactive file:///home/system/svnroot/xxx/tags/test-common2/ ||
/usr/local/bin/svn15 --non-interactive update ..
D www/hello.html
A www/ielogo_white.gif
U www/index.html
  U www

Fetching external item into 'www/common'
svn: '/home/system/svnroot/common' is not a working copy
svn: Can't open file '/home/system/svnroot/common/.svn/entries': No such
file or directory

Fetching external item into 'www/common'
A www/common/hello.php
Updated external to revision 660.

Updated to revision 660.

# /usr/local/bin/svn15 propget svn:externals www

^/common/dev/ common
--- END ---

The externals break on the switch, but subsequently will get fetched if
I do an update. The same activity was observed for http/https URLs
(using bundled NEON on client and mod_svn on server). It works fine on
checkout, too. The working copies are all 1.5, whereas the repository
is still 1.4 - not sure if that makes a difference.

Suggested solution:
Fix switch subcommand to properly deal with the new externals format

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe_at_subversion.tigris.org
For additional commands, e-mail: dev-help_at_subversion.tigris.org
Received on 2008-03-30 19:40:11 CEST

This is an archived mail posted to the Subversion Dev mailing list.