[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [PATCH] issue #3071: allow built-in diff to be specified as diff-cmd

From: Daniel Shahaf <d.s_at_daniel.shahaf.co.il>
Date: Tue, 25 Mar 2008 22:37:52 +0200

Daniel Danger Bentley wrote on Tue, 25 Mar 2008 at 03:09 -0400:
> Hmm, I understand the concern about using the empty string to mean "internal
> diff".
>
...
> It seems to me what we are discussing is one option (which diff command
> should be used), and so it makes sense to specify that option in one place.
>

Makes sense to me too.

> Using "" to mean "built-in" may be confusing. I get that. Another option
> would be to be "builtin" to mean "built-in", but that 1) prevents running
> binaries named "builtin"

     --diff-cmd=/path/to/builtin

Is there actually a 'builtin' binary anywhere that does diffs?

> and 2) is easy to confuse with something else; say
> "built-in".
>

It is equally easy to confuse --diff-cmd/--diffcmd, -R/-r, and so on.

If the wrong name is specified, it won't be executable and an error
message will be given. That error message could point people to the
help, which lists the correct spelling.

> Having "" mean default matches informal user expectation, I posit.

Usually, it means to use the empty string, which may or may not be
a legal value. For example, svn ci -m "" doesn't commit with a default
log message, svn up -r "" doesn't update to a default revision, and so
on.

Daniel

> Uninitialized strings in languages that have a default are "", and supply
> the value most like null to specify that you meant no value seems
> consistent.
>
> I'd love to do what will make this work, but I think that keeping it as one
> option (especially when it's documented that "" is a special value instead
> of a non-sensical one to specify) is going to be simplest when integrated
> over many variables. The discussion on the bug (
> http://subversion.tigris.org/issues/show_bug.cgi?id=3071 ) settled with jph
> saying this wasn't a perfect syntax, but acceptable. It's not perfect, but
> I think it might be the least flawed out there.
>
> Thank you for the help/guidance,
> -Dan
>
> On Mon, Mar 24, 2008 at 4:33 PM, C. Michael Pilato <cmpilato_at_collab.net>
> wrote:
>
>> Stefan Sperling wrote:
>>> On Mon, Mar 24, 2008 at 05:05:06AM -0400, Daniel Danger Bentley wrote:
>>>> Ping.
>>>>
>>>> Is there something I can do to help this process along or that I
>> forgot to
>>>> do initially? Should I pick a reviewer based on revision history?
>>>
>>> Since no-one else has commented so far, let me just give you my
>>> (non-authoritative!) take on the design of your patch.
>>>
>>> I think making an empty string carry special semantics is wrong UI
>> design.
>>> It's not obvious enough.
>>>
>>> What would be better IMHO (and various standard UNIX tools do the
>>> same thing) is adding an additional option that overrides all previous
>>> --diff-cmd options, and also config file settings.
>>>
>>> Maybe --force-internal-diff ?
>>
>> As a commentary about the proposed UI, I have to agree with Stefan here.
>>
>> --
>> C. Michael Pilato <cmpilato_at_collab.net>
>> CollabNet <> www.collab.net <> Distributed Development On Demand
>>
>>
>
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe_at_subversion.tigris.org
For additional commands, e-mail: dev-help_at_subversion.tigris.org
Received on 2008-03-25 21:38:23 CET

This is an archived mail posted to the Subversion Dev mailing list.