[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: svn commit: r27633 - trunk/subversion/libsvn_ra_neon

From: Hyrum K. Wright <hyrum_wright_at_mail.utexas.edu>
Date: 2007-11-08 03:13:19 CET

cmpilato@tigris.org wrote:
> Author: cmpilato
> Date: Tue Nov 6 12:54:33 2007
> New Revision: 27633
>
> Log:
> Split libsvn_ra_neon/fetch.c into 5 different files, four of which
> service one RA API each, the other (fetch.c) which continues to hold
> all the rest of the stuff it used it. This required *no* code
> changes -- only intra-file motion.
>
> * subversion/libsvn_ra_neon/get_locks.c
> New, copied from fetch.c, but with only the code supporting
> svn_ra_neon__get_locks() left.
>
> * subversion/libsvn_ra_neon/get_location_segments.c
> New, copied from fetch.c, but with only the code supporting
> svn_ra_neon__get_location_segments() left.
>
> * subversion/libsvn_ra_neon/get_locations.c
> New, copied from fetch.c, but with only the code supporting
> svn_ra_neon__get_locations() left.
>
> * subversion/libsvn_ra_neon/get_dated_rev.c
> New, copied from fetch.c, but with only the code supporting
> svn_ra_neon__get_dated_rev() left.
>
> * subversion/libsvn_ra_neon/fetch.c
> (drev_report_elements, getlocks_report_elements, drev_baton_t,
> drev_start_element, drev_end_element, svn_ra_neon__get_dated_revision,
> get_locations_baton_t, gloc_report_elements, gloc_start_element,
> svn_ra_neon__get_locations, gls_report_elements, gls_start_element,
> get_location_segments_baton_t, svn_ra_neon__get_location_segments,
> get_locks_baton_t, getlocks_start_element, getlocks_cdata_handler,
> getlocks_end_element, svn_ra_neon__get_locks): Remove all the stuff
> now present in the other four files.
>
> Added:
> trunk/subversion/libsvn_ra_neon/get_dated_rev.c
> - copied, changed from r27617, /trunk/subversion/libsvn_ra_neon/fetch.c
> trunk/subversion/libsvn_ra_neon/get_location_segments.c
> - copied, changed from r27617, /trunk/subversion/libsvn_ra_neon/fetch.c
> trunk/subversion/libsvn_ra_neon/get_locations.c
> - copied, changed from r27617, /trunk/subversion/libsvn_ra_neon/fetch.c
> trunk/subversion/libsvn_ra_neon/get_locks.c
> - copied, changed from r27617, /trunk/subversion/libsvn_ra_neon/fetch.c
> Modified:
> trunk/subversion/libsvn_ra_neon/fetch.c

This commit, combined with the recent spate of consistification within
our code got me thinking about file naming conventions. Currently, we
use both - and _ in place of a space in the code tree:

hwright@spock:~/dev/svn-trunk$ find . -name '*-*.c' | wc -l
91
hwright@spock:~/dev/svn-trunk$ find . -name '*_*.c' | wc -l
61

I know this is pretty bikesheddy, but would it be worth it to
consistently use one version over the other?

-Hyrum

Received on Thu Nov 8 03:13:18 2007

This is an archived mail posted to the Subversion Dev mailing list.