[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Misleading/incomplete building instructions provided by m4-macro SVN_DOWNLOAD_APRUTIL (file an issue?)

From: Nicolai, Johannes <Johannes.Nicolai_at_student.hpi.uni-potsdam.de>
Date: 2007-10-28 08:42:01 CET

If you checkout the source of subversion, generate your configure script and run it without having libaprutil installed, configure will exit after having executed the m4 macro SVN_DOWNLOAD_APRUTIL in ac-macros/apr-util.m4

The text, this m4 macro outputs suggests to directly checkout the aprutil source code (command is provided) and run configure again. If you run configure again, it will run into an error because there is no configure script (yet) for aprutils. You first have to run buildconf in the checked-out directory apr-util before (that is not mentioned in th m4 macro and might confuse people).

Question #1: Is this worth a P5 issue?

Question #2: May I provide a patch that changes the m4 macro in a way it tells you about the buildconf command or should I modify a m4 macro so that it automatically calls buildconf before it tries to execute configure?

Question #3: The same problem occurs for libapr as well. Should I file another issue for this?

Regards

Johannes Nicolai

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Sun Oct 28 08:42:15 2007

This is an archived mail posted to the Subversion Dev mailing list.