[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Bumping Python requirement to (at least) 2.2

From: David Glasser <glasser_at_davidglasser.net>
Date: 2007-10-18 03:41:56 CEST

We currently require Python only for the build-from-checkout and test
system, not for building from tarballs. We require 2.2 for Windows
and 2.0 for Unix.

Here is a timeline:
21-Dec-2001: Python 2.2 released.
23-Feb-2004: Subversion 1.0.0 released.
30-Nov-2004: Python 2.4 released.
17-Oct-2007: I am writing these words.

I think we should bump the Python requirement to at least 2.2, if not
2.4. This will let us use modern features like subprocess (which
comes with 2.4 and works with 2.2) in the test suite. There's a nice
table in http://www.python.org/dev/peps/pep-0291/ which shows what
language features we would be able to use.

--dave

-- 
David Glasser | glasser_at_davidglasser.net | http://www.davidglasser.net/
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Thu Oct 18 03:42:08 2007

This is an archived mail posted to the Subversion Dev mailing list.