[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Silent working copy corruption after "svn revert"

From: Vincent Lefevre <vincent+svn_at_vinc17.org>
Date: 2007-09-14 11:38:18 CEST

On 2007-09-14 11:21:19 +0200, Erik Huelsmann wrote:
> Probably. I wonder how those revert files could have gotten left
> behind. I'm working on the wc code at the moment and I have seen some
> code which could indeed create this kind of problem. I'll fix it and
> propose for backporting.
>
> Do you build your own client? If so, I'll mail you when I've committed
> the fix. You can backport yourself if you want.

I use the binary package on Debian, and MacPorts (where I can
use patches) on Mac OS X.

> If you just remove the *.svn-revert files (for those files which
> aren't scheduled for replacement), that will prevent similar problems
> in the future (until, ofcourse new ones get left behind). Do you have
> time to find out how to create this kind of problem?

I'll try to reproduce it this afternoon.

-- 
Vincent Lefèvre <vincent_at_vinc17.org> - Web: <http://www.vinc17.org/>
100% accessible validated (X)HTML - Blog: <http://www.vinc17.org/blog/>
Work: CR INRIA - computer arithmetic / Arenaire project (LIP, ENS-Lyon)
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Fri Sep 14 11:34:48 2007

This is an archived mail posted to the Subversion Dev mailing list.