[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: svn commit: r26483 - in trunk/subversion: include/private libsvn_fs_util libsvn_wc

From: Lieven Govaerts <svnlgo_at_mobsol.be>
Date: 2007-09-10 21:41:37 CEST

Daniel Rall wrote:
> On Sat, 08 Sep 2007, David Glasser wrote:
>
>
>> On 9/6/07, dlr@tigris.org <dlr@tigris.org> wrote:
>>
>>> Author: dlr
>>> Date: Thu Sep 6 10:09:35 2007
>>> New Revision: 26483
>>>
>>> Log:
>>> Formalize a flow control macro which we apparently use in several
>>> places already.
>>>
>>> * subversion/include/private/svn_flowcontrol.h
>>> New header file, providing a MAYBE_GOTO() macro.
>>>
>> I'm not really sure how compelling this is: I don't think that
>>
>> MAYBE_GOTO(cleanup, err);
>>
>> is actually any clearer than
>>
>> if (err) goto cleanup;
>>
>> It's longer, makes the reader think a little more (since it isn't just
>> standard C conditional), and doesn't really hide any complexity...
>>
>
> I had similar misgivings. I'm certainly not attached to it -- was
> just cleaning out a WC...
>
>
Sorry for not following up earlier. Originally - in the context of
r26340 - the idea of having a CLEANUP_ON_ERROR macro made sense, but I
agree it doesn't make the code more readable. So, while I was +1 on
adding above change, I'm +1 on rolling back too ;)

Lieven

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Mon Sep 10 21:35:36 2007

This is an archived mail posted to the Subversion Dev mailing list.