[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: subversion installation on Parisc64

From: Rick Jones <rick.jones2_at_hp.com>
Date: 2007-08-27 19:30:33 CEST

Burkhard Neinhues wrote:
> Hi,
>
> I'm trying to install subversion on HP-UX for some time now.
> I had success with 1.4.3 with all the apr libraries including apr-iconv
> installed before calling the
> configure of subversion. Not using apr-iconv on Parisc will trigger
> unresolved symbols for libiconv_open.
>
> However, this breaks for subversion 1.4.4 for various reasons:
> - the Parisc linker can't deal with dependent shared libraries in a sane
> manner.
> - the subversion-deps package doesn't include apr-iconv -> libiconv_open
> issues which can't be easily solved on HPs.

If you think there are problems in the HP-UX linker running on PA-RISC systems,
the hpux-devtools@cxx.cup.hp.com mailing list might be a good place to discuss
it. (If you aren't already excercising your support contracts and in contact
with the Response Center.)

When/if you do send a message to hpux-devtools please be painfully specific
about OS rev, linker rev, patches installed etc etc. and why you believe the
linker's current behaviour to be not sane.

sincerely,

rick jones

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Mon Aug 27 19:32:20 2007

This is an archived mail posted to the Subversion Dev mailing list.