[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Problems with svn blame -g

From: Mark Phippard <markphip_at_gmail.com>
Date: 2007-08-21 03:16:18 CEST

On 8/20/07, Hyrum K. Wright <hyrum_wright@mail.utexas.edu> wrote:
> Mark Phippard wrote:
> > Using my sample merge tracking repository that is used in the svn log -g tests:
> >
> > $ svn blame -g file:///Users/mphippard/repositories/merge-tracking/trunk/index.html
> >
> > Works OK.
> >
> > $ svn blame -g file:///Users/mphippard/repositories/merge-tracking/trunk/products/index.html
> > svn: Can't open file '/tmp/tmp.2.tmp': No such file or directory
>
> Fixed in r26207.

It now runs to completion, but I see user "merger" from r12 in the
output which implies there is a bug of some sort. I think this was a
case where branchA was merged to branchB in r12 and then to trunk
later. So maybe it did not follow the merge back to its source?

> > $ svn blame -g file:///Users/mphippard/repositories/merge-tracking/trunk/products/roadmap.html
> > Bus error
>
> Fixed in r26211.

This still crashes for me on OSX. I have not tried it on Windows.

-- 
Thanks
Mark Phippard
http://markphip.blogspot.com/
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Tue Aug 21 03:14:11 2007

This is an archived mail posted to the Subversion Dev mailing list.