[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: svn commit: r25253 - trunk/subversion/bindings/swig/ruby/svn

From: Kouhei Sutou <kou_at_cozmixng.org>
Date: 2007-06-05 12:36:30 CEST


In <20070604170809.GM21438@despot.finemaltcoding.com>
  "Re: svn commit: r25253 - trunk/subversion/bindings/swig/ruby/svn" on Mon, 4 Jun 2007 10:08:09 -0700,
  Daniel Rall <dlr@collab.net> wrote:

> It's the same in Java and C and Python and pretty much every language
> (thus the original split between "mergeinfo" and "merge info"). I
> don't have a strong preference here, but in the core C API, we wanted
> to pick one and go with it, and the one chosen was "mergeinfo", to
> help illuminate the fact that it's a single term, and not verb_noun,
> which in some API names turned out to be quite confusing.

The problem of the original is that some API names use
"mergeinfo" and others use "merge info". In the Ruby
bindings, we provide both "mergeinfo" and "merge_info".

Users will not be confused because one is just alias of
other. They can use both of them what they like in their
script. And Ruby has many aliases. For example, collect and
map, size and length, and so on. I think those aliases help
users to write their script what they like. I hope the Ruby
bindings have Rubyish API because the Ruby bindings is used
by Rubyist.


To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Tue Jun 5 12:36:54 2007

This is an archived mail posted to the Subversion Dev mailing list.

This site is subject to the Apache Privacy Policy and the Apache Public Forum Archive Policy.