[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [PATCH] ctypes-python-bindings branch Move client helper classes to new file

From: David James <james_at_cs.toronto.edu>
Date: 2007-06-04 07:28:56 CEST

Hi Sage,

Thanks for the patch!

I don't think we need to create a separate class for "client helpers",
as the distinction between client.py and client_helpers.py wouldn't
really be that clear from a user perspective. At the same time, I do
think we should move the mismash of classes in client.py into separate
files which more logically reflect their purposes.

After thinking for a while, I came up with some module names which I
think better reflect the contained classes:
   - repos.py: Repository-related classes (e.g. for accessing the
repository, or for wrapping repository-related datatypes)
   - types.py: Wrappers for generic Subversion and APR datatypes (e.g.
dates, streams, strings, pools, etc).
   - auth.py: Authorization and authentication-related classes

We don't have any wrappers for the client layer per-se yet (other than
our client-like wrappers for the RA layer), so I've deleted client.py
and split up its contents among repos.py, types.py, and auth.py.

I committed these refactorings in r25273-r25279. I think that this new
layout is clearer.

Let me know if you have more ideas. Keep up the good work!



On 5/30/07, Sage La Torra <sagelt@gmail.com> wrote:
> Following up on the renames to the python classes yesterday, this
> patch moves a lot of helper classes from client.py to
> client_helpers.py (a new file). This is based on some talk David James
> and I had on cleaning things up, it makes more sense to keep client.py
> only for repository objects and use another file for all the helper
> objects. The _fs* objects are kept in client.py so that they can still
> be private.
> I chose the name client_helpers.py to be as descriptive as possible.
> The classes do a number of things, so I wasn't able to come up with a
> more descriptive name. If there are any suggestions as to a better
> name for the file to hold the helper classes, feel free to suggest it.
> I think client_helpers.py is simple and descriptive, but I'm not set
> on this name if a better one exists.
> [[[
> Move python helper classes from client.py to client_helpers.py (new
> file). With the exception of private classes (_fs*) all non-repository
> classes are moved from client.py to client_helpers.py.
> Patch by: Sage La Torra <sagelt@gmail.com>
> * csvn/client.py:
> (SvnDate, LogEntry, _LogMessageReciever, User, RepositoryURI, ):
> Removed from this file, moved to csvn/client_helpers.py. _fs* still
> reside here, due to visibility.
> * csvn/client_helpers.py:
> (SvnDate, LogEntry, _LogMessageReciever, User, RepositoryURI, ): New
> home for all these functions.
> ]]]
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
> For additional commands, e-mail: dev-help@subversion.tigris.org

To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Mon Jun 4 07:29:10 2007

This is an archived mail posted to the Subversion Dev mailing list.

This site is subject to the Apache Privacy Policy and the Apache Public Forum Archive Policy.