Following up on the renames to the python classes yesterday, this
patch moves a lot of helper classes from client.py to
client_helpers.py (a new file). This is based on some talk David James
and I had on cleaning things up, it makes more sense to keep client.py
only for repository objects and use another file for all the helper
objects. The _fs* objects are kept in client.py so that they can still
be private.
I chose the name client_helpers.py to be as descriptive as possible.
The classes do a number of things, so I wasn't able to come up with a
more descriptive name. If there are any suggestions as to a better
name for the file to hold the helper classes, feel free to suggest it.
I think client_helpers.py is simple and descriptive, but I'm not set
on this name if a better one exists.
[[[
Move python helper classes from client.py to client_helpers.py (new
file). With the exception of private classes (_fs*) all non-repository
classes are moved from client.py to client_helpers.py.
Patch by: Sage La Torra <sagelt@gmail.com>
* csvn/client.py:
(SvnDate, LogEntry, _LogMessageReciever, User, RepositoryURI, ):
Removed from this file, moved to csvn/client_helpers.py. _fs* still
reside here, due to visibility.
* csvn/client_helpers.py:
(SvnDate, LogEntry, _LogMessageReciever, User, RepositoryURI, ): New
home for all these functions.
]]]
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Thu May 31 01:03:40 2007