On Fri, 23 Mar 2007, Kouhei Sutou wrote:
> 2007/3/23, firstname.lastname@example.org <email@example.com>:
> >Author: dlr
> >Date: Thu Mar 22 14:11:00 2007
> >New Revision: 24027
> >Merge the merge-tracking branch to trunk.
> >Modified: trunk/subversion/include/svn_types.h
> >--- trunk/subversion/include/svn_types.h (original)
> >+++ trunk/subversion/include/svn_types.h Thu Mar 22 14:11:00 2007
> >@@ -702,6 +702,24 @@
> >+ * Return a copy of @a range, allocated in @a pool.
> >+ *
> >+ * @since New in 1.5.
> >+ */
> >+svn_merge_range_t *
> >+svn_range_dup(svn_merge_range_t *range, apr_pool_t *pool);
> I think we should rename to svn_merge_range_dup to unify other
> function name convention.
+1 -- feel free to make this change.
> By the way, why do we use 'mergeinfo' prefix instead of 'merge_info'
> prefix? I'm confused because
> subversion/include/private/svn_fs_merge_info.h uses 'merge_info' prefix
> as its filename and some names.
I prefer "merge info" (since it's two words). I think "mergeinfo" was
used as the library prefix as a simple abbreviation. I suppose we
should change to "mergeinfo" for the sake of consistency.
Thanks for the review, Kou.
Received on Fri Mar 23 06:09:13 2007
- application/pgp-signature attachment: stored