[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: svnadmin dump/verify/load uses svn_path_join

From: Lieven Govaerts <svnlgo_at_mobsol.be>
Date: 2007-03-19 23:31:05 CET

D.J. Heap wrote:
> On 3/14/07, Lieven Govaerts <svnlgo@mobsol.be> wrote:
>> Justin Erenkrantz wrote:
> [snip]
>> > Is it worth to standardize on (say) _dirent_ or _uri_ to avoid the
>> > _path_ ambiguity? I've never cared for the _path_ name to begin with.
>> That's probably the first thing we need to do, standardize the naming.
>> Some path functions use 'uri' already btw, so I propose to keep using
>> that term.
>>
> Yes, we need to get the various path-names straightened out and the
> above sounds good to me. I guess we'd have something like
> _local_dirent_, _internal_dirent_, _repos_uri_, and
> _internal_repos_uri to match the different usages?
Reverted the windows path handling code in r23907.

Won't dirent and uri be sufficient? The uri and the paths inside the
repository have the same structure, no need to make a difference there.

I left the svn_path_is_root function in the code, so if I use above
conventions I'll rename it to svn_path_dirent_is_root before 1.5 will be
branched. I don't think any of the currently existing functions will
change in meaning, so I won't have to rev any of the functions.

There's probably some 20 svn_path functions that need to be deprecated
and replaced by svn_path_dirent and svn_path_uri functions. I can let
the deprecated svn_path* functions forward to svn_path_uri_*, which is
basically what they are right now. There may be no need to convert all
of them, I'll look into that after 1.5 is branched

Lieven

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Mon Mar 19 23:31:23 2007

This is an archived mail posted to the Subversion Dev mailing list.