[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Possible SVN Relocate bug

From: Scott Hendrickson <sahendrickson_at_gmail.com>
Date: 2007-03-13 17:46:15 CET

Has anyone been able to verify whether this is a bug?
Thanks,
-- Scott

On 3/9/07, Scott Hendrickson <sahendrickson@gmail.com> wrote:
> (Apologies if this has appeared multiple times-- I originally posted
> it on dev list when unsubscribed, then the user list, but with no
> reponse-- I don't know what a typical window for a message being
> moderated is, so in case it has not gone through because I was not
> subscribed to dev, I'm reposting it now that I am subscribed)
>
> I have an svn repository that was recently moved to a different
> server. A user who had previously checked out a folder within the
> repository was unable to relocate their copy to this new server. They
> kept getting the following error:
>
> PROPFIND request failed on '/svn/repository'
> PROPFIND of '/svn/repository': 403 Forbidden ( https://domain.name )
>
> They were able to check out a fresh copy from the new repository, but
> were not able to relocate their old copy to it.
>
> After looking in to this (and doing a little testing) It appeared that
> the user could not relocate the repository unless they had permission
> to read and write (possibly just read -- I only tested with both read
> and write) access to the root of the repository. When I added them as
> having rw permission in [/], they could relocate the repository
> without any problems. I've attached some (shortened) configuration
> files and log messages below. Hopefully they will help. Of note,
> notice that the error.log file shows them trying to access PROPFIND on
> repository:/ when they were relocating a subfolder within it.
>
> I'm using svn version 1.4.3 on my client, and 1.3.2 on the server.
>
> If this is a bug, do I need to do more?
> If this is a misconfiguration on my part, how should I fix it?
>
> Thank you,
> -- Scott
>
> ---- Apache Config file contains:
>
> <Location /svn>
>
> DAV svn
> SVNParentPath /var/svn
> SVNAutoversioning on
>
> Order Allow,Deny
> Allow from all
>
> <IfModule mod_ssl.c>
> SSLRequireSSL
> </IfModule>
>
> AuthType Basic
> AuthName "SVN Repositories"
> AuthUserFile /etc/apache2/.htpasswd
> AuthzSVNAccessFile /etc/apache2/svn.authz
>
> Require valid-user
>
> </Location>
>
> ---- svn.authz
>
> [/]
> * =
>
> [repository:/some/folder]
> user = rw
>
> ---- Apache error.log
>
> [Mon Mar 05 22:21:03 2007] [error] [client xxx.xxx.xxx.xxx] Access
> denied: 'user' PROPFIND repository:/
>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Tue Mar 13 17:46:38 2007

This is an archived mail posted to the Subversion Dev mailing list.