Hey, Peter, can I make a suggestion? "svn_load_dirs" was never a very
descriptive name anyway, for a tool that essentially does what most
people think of as "vendor branches" (although some object to the
latter term on the grounds that often the source is not a vendor but
another open source project).
In any case, both in order to avoid identity confusion and to have a
better name, maybe you could name it something wholly new, and just
say in its documentation that it's intended as a drop-in replacement
Possibilities: "sourcedrop", "svn_vbranch", "sidefork"... I dunno, I'm
just making stuff up, probably you can come up with something better.
Peter Samuelson <firstname.lastname@example.org> writes:
> ----- Forwarded message from dann frazier <email@example.com> -----
> From: dann frazier <firstname.lastname@example.org>
> Subject: Bug#406292: pysvn_load_dirs: a freely redistributable implementation of svn_load_dirs
> (I'm not subscribed to this list, please CC me on replies)
> Due to licensing issues w/ svn_load_dirs, I have started a
> reimplementation of this tool, currently under the GPL license. This
> implementation is intended to become a drop-in replacement for
> svn_load_dirs, though it is currently missing some of its features -
> not uncoincidentally the ones I never used in the original. I plan to
> increase compatability over time.
> pysvn_load_dirs uses the pysvn module mostly because that's the
> one I'm most familiar with. Porting to the libsvn interface, at a
> glance, looks pretty straightforward.
> I'm interested in bug reports and, of course, patches :) I'm currently
> developing in non-public svn repository until I find a public place to
> host it.
>  http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=398035
>  -no_user_input, -p, -svn_username, -svn_password, -v & -wc
> dann frazier | HP Open Source and Linux Organization
To unsubscribe, e-mail: email@example.com
For additional commands, e-mail: firstname.lastname@example.org
Received on Wed Feb 7 02:18:46 2007