[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Neon 0.26.2

From: D.J. Heap <djheap_at_gmail.com>
Date: 2006-11-20 15:40:29 CET

On 11/20/06, Stefan Küng <tortoisesvn@gmail.com> wrote:
> Samay wrote:
>
> > I tested the binaries with abpve patch and it doesnt work. Specific to
> > link provided above (fix by Stefan) seems like a different problem but
> > with similar error. Difference from this bug summary is
> > a) its SSPI on & Basic On (or Basic Off), Mod_auth_kerb 5.0_RC6, RHEL4,
> > Active Directory 2k3. (works fine with Firefox and IE)
> > b) user computer is in the AD domain.
>
> The patch only fixes one problem. I haven't added the additional check
> in all places. You can find two or three more places in the same file
> (where the patch applies to) which call svn_auth_first_credentials().
> Can you try to patch all those places and try again please?
> (don't search for "(attempt == 0)" but for svn_auth_first_credentials()
> - in the other places it's "(try == 0)" which has to be patched)
>

I checked those, but it looked like they only dealt with bad server
certs, or client cert auth. Anyway, I'll try patching those as well
and posting a new test build, but it will might be next week before I
have time.

Neon debug tracing can be turned on in the Subversion servers config
file -- set neon_debug_mask = 255 in the global section of the servers
file.

DJ

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Mon Nov 20 15:40:55 2006

This is an archived mail posted to the Subversion Dev mailing list.