[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Error in authz file

From: Peter Lundblad <plundblad_at_google.com>
Date: 2006-11-17 18:11:21 CET

Malcolm Rowe writes:
> On Fri, Nov 17, 2006 at 12:55:20PM +0100, Peter Lundblad wrote:
> > Daniel Rall writes:
> > > On Thu, 16 Nov 2006, Mats Fors wrote:
> > >
> > > Are you sure this is the authz file which is actually in use? Unless
> > > those comments at the end of the line are a problem, I'd expect your
> > > authz file to have a improperly defined rule like:
> > >
> >
> > But this is exactly the problem. The config file parser does not strip
> > off comments inside values. So, put your comments above the lines or something.
>
> It would be nice if the authz parser complained about the first invalid
> character in the value, rather than (it appears) the last. In most
> cases of this type, that'd be '#', which would more quickly clue us in
> on the problem.
>
A quick look at the code yields that it shold do so. I haven't tried
it and don't know why it complains about the 's', though. So, if the quoted
config file is the one that generates the error, then this might be a
bugt.

Later,
//Peter

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Fri Nov 17 18:13:33 2006

This is an archived mail posted to the Subversion Dev mailing list.