Re: [PATCH][merge-tracking] Reduce one query to sqlite while retrieveing the mergeinfo.
On Wed, 15 Nov 2006, Kamesh Jayachandran wrote:
> Reduce one query to sqlite.
> * subversion/libsvn_fs_util/merge-info-sqlite-index.c
> changing the name of the arg 'rev' to 'lastmerged_rev'.
> Don't deduce the 'lastchanged_rev' as the caller himself would give it
> as 'lastmerged_rev'.
> Don't get the count of records rather get the lastmerged_rev itself.
Thanks Kamesh! Committed to the branch in r22309.
p.s. Remember that -- long-term -- we're probably going to scrap this
schema, so right now it's most efficient to focus our efforts on
getting a comprehensive, end-to-end solution working by building the
remaining unfinished pieces of functionality.
Received on Thu Nov 16 19:28:24 2006
- application/pgp-signature attachment: stored
This is an archived mail posted to the Subversion Dev