[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: can't use apr_time_ansi_put

From: D.J. Heap <djheap_at_gmail.com>
Date: 2006-10-29 21:17:58 CET

On 10/29/06, Andreas Richter <ar@oszine.de> wrote:
[snip]
>
> Hm. It looks like my calls are correct. In apr_time.h (from the
> svn-win32-1.4.0_dev.zip) apr_time_ansi_put ist declared as:
>
> APR_DECLARE(apr_status_t) apr_time_ansi_put(apr_time_t *result,
> time_t input);
>
>
> and my call (for example) is:
>
> apr_time_t *result;
> time_t input;
>
> apr_time_ansi_put( result, input );
>
> MSVC++2005 compiles it correct but can't link it. I become the following
> (german) error message:
>
> error LNK2019: Verweis auf nicht aufgelöstes externes
> Symbol "__imp__apr_time_ansi_put@12" in Funktion ""public: __thiscall
> svn::DateTime::DateTime(class QDateTime const &)"
> (??0DateTime@svn@@QAE@ABVQDateTime@@@Z)"..
>
> > Maybe someone with more win32 experience can confirm whether this is a
> > general problem with the win32 development package.
>
> Are there any known problems in the development packages svn-win32-1.4.0?
>

The issue is a difference in the definition of time_t -- VC2005
changed it to a 64bit type by default and these libraries are built
with VC6. Set the _USE_32BIT_TIME_T preprocessor definition for your
VC2005 project and it will work. Or you could also rebuilt APR
yourself with VC2005 if you want the 64bit time_t.

DJ

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Sun Oct 29 21:18:16 2006

This is an archived mail posted to the Subversion Dev mailing list.