[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: On backporting r21531 to 1.4.x.

From: D.J. Heap <djheap_at_gmail.com>
Date: 2006-10-09 23:34:40 CEST

On 10/9/06, Samay <getafix123@hotmail.com> wrote:
[snip]
>
> with svn 1.4.x neon0.26.x, it just doesnt work. please refer to thread
> http://svn.haxx.se/users/archive-2006-09/0950.shtml for a legnthy discussion
> on how0.25.x Neon works but 0.26.1 doesnt. We resolved this issue by using
> 1.4.x compiled against 0.25.x of Neon (Thanks DJ Heap). Since TSVN 1.4.x is
> shipped with Neon 0.25.x it was ok.

SSPI is working fine with neon 0.26.1 (dynamic options and desired
auth behavior aside) based on the testing I did (admittedly not
exhaustive, but quite a bit) and the feedback I've gotten. Isn't your
problem specific to GSSAPI?

GSSAPI (related to SSPI but a different auth protocol?) seems to have
trouble (as in crashes) with 0.26.1 but no one can provide a server to
test against and setting up a GSSAPI server seems to be rather
involved. I'm also fairly sure that the GSSAPI problem is not
specific to Windows. And my understanding is that GSSAPI doesn't work
at all in neon 0.25.5 -- it just always drops back to BASIC, but I
haven't tested that myself.

DJ

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Mon Oct 9 23:35:20 2006

This is an archived mail posted to the Subversion Dev mailing list.