[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: JavaHL JDK compatibility

From: Conor MacNeill <conor_at_cenqua.com>
Date: 2006-10-04 18:16:22 CEST

Garrett Rooney wrote:
> On 10/4/06, Conor MacNeill <conor@cenqua.com> wrote:
>> Hi,
>>
>> The current javahl build available with Subversion 1.4 (at least for
>> windows) requires JDK 1.5 to run since the classfile major version is
>> 49. Was this intentional?
>
> I can't imagine why, I don't think we use any 1.5 features.
>
>> It may be a good idea to add a -target setting (and maybe -source) to
>> the javac command when building the next version.
>
> Sounds reasonable to me, got a patch to add it to the build system?
>

Cool - I'll work one up.

Thanks
Conor

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Wed Oct 4 18:16:55 2006

This is an archived mail posted to the Subversion Dev mailing list.