[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [PATCH] function name change as per convention(round 3).

From: Kamesh Jayachandran <kamesh_at_collab.net>
Date: 2006-09-13 13:48:51 CEST

Daniel Rall wrote:
> On Thu, 07 Sep 2006, Kamesh Jayachandran wrote:
> ...
>> Don't use intralibrary prefix for a static function
>> * subversion/libsvn_diff/token.c
>> (diff_tree_insert_token): Rename from svn_diff__tree_insert_token.
>> (svn_diff__get_tokens): Adjust for above rename.
>> * subversion/libsvn_diff/lcs.c
>> (diff_snake): Rename from svn_diff__snake.
>> (svn_diff__lcs): Adjust for above rename.
>> (diff_lcs_reverse): Rename from svn_diff__lcs_reverse.
>> (svn_diff__lcs): Adjust for above rename.
> Why do this functions still retain a "diff_" prefix? We don't do that
> everywhere else -- is that specific to this module?

This makes me to think whether to have this change at all!
All these function names derive names from the operations and the data
structures over which they operate.
For example,
'svn_diff__lcs_reverse' reverses 'svn_diff__lcs_t'
'svn_diff__snake' some operation I could not understand over
'svn_diff__tree_insert_token' insert operation over 'svn_diff__tree_t'.

Either we should leave them as it is today considering them as special
Or we should have them just cutting off 'svn' prefix from their names
that is what my patch does.

Now I prefer leaving them as it is :).
With regards
Kamesh Jayachandran

To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Wed Sep 13 13:48:50 2006

This is an archived mail posted to the Subversion Dev mailing list.

This site is subject to the Apache Privacy Policy and the Apache Public Forum Archive Policy.