[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Another 1.4 release critical bug

From: Philip Martin <philip_at_codematters.co.uk>
Date: 2006-08-01 01:05:51 CEST

Branko ╚ibej <brane@xbc.nu> writes:

> Garrett Rooney wrote:
>> On 7/31/06, Philip Martin <philip@codematters.co.uk> wrote:
>>
>>> Do any developers regularly build/test using --enable-dso? Has anyone
>>> ever done any stress testing with --enable-dso?
>>
>> Personally, I've never done so, I don't know if anyone else does.
>
> Since we're not actually testing that stuff, and it seems to be a huge
> potential problem, why don't we just disable DSO in 1.4?

When I asked last year Greg Hudson replied that some packagers use it:

http://svn.haxx.se/dev/archive-2005-07/1344.shtml

and we have had a small number of bug reports from users that were a
result of --enable-dso, although that could be a reason to disable it.

> I think it's a
> misfeature the way it's implemented now, anyway.

Given that Subversion with --disable-dso still tries to load DSOs I
tend to agree.

-- 
Philip Martin
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Tue Aug 1 01:06:32 2006

This is an archived mail posted to the Subversion Dev mailing list.

This site is subject to the Apache Privacy Policy and the Apache Public Forum Archive Policy.