On Sat, 29 Jul 2006, Julian Foad wrote:
> Daniel Rall wrote:
> >Perhaps the parameter should be renamed instead? We usually refer to
> >its type of data as "copyfrom", as opposed to just "copy".
> I agree, and here's the patch for review in case I'm wrong in thinking this
> would not be an API or ABI change.
> Rename some API parameters for consistency. This does not constitute an API
> or ABI change, as the parameters are only within a pointer-to-function type.
> * subversion/include/svn_delta.h
> (svn_delta_editor_t): Rename add_file()'s 'copy_path' and 'copy_revision'
> parameters to 'copyfrom_path' and 'copyfrom_revision' to match its doc
> string and for consistency with add_dir() and many (but not all)
> that implement this interface.
> Index: subversion/include/svn_delta.h
> --- subversion/include/svn_delta.h (revision 20897)
> +++ subversion/include/svn_delta.h (working copy)
> @@ -810,8 +810,8 @@ typedef struct svn_delta_editor_t
> svn_error_t *(*add_file)(const char *path,
> void *parent_baton,
> - const char *copy_path,
> - svn_revnum_t copy_revision,
> + const char *copyfrom_path,
> + svn_revnum_t copyfrom_revision,
> apr_pool_t *file_pool,
> void **file_baton);
Looks fine (no compat issues), +1.
I'm guessing that our SWIG stuff doesn't expose this API, but if it
does, it could have some impact there.
Received on Mon Jul 31 08:07:56 2006
- application/pgp-signature attachment: stored