[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Building and Testing Python, Perl, and Ruby Bindings

From: D.J. Heap <djheap_at_gmail.com>
Date: 2006-07-13 14:20:09 CEST

On 7/12/06, David James <djames@collab.net> wrote:
[snip]
>
> Have you tried building Subversion with SWIG 1.3.25? These problems
> involving the #error and #warning preprocessor directive only occur
> with SWIG 1.3.26 or later.
>

With 1.3.25 I get:

------ Build started: Project: swig_python_core, Configuration:
Release Win32 ------
Performing Custom Build Step
c:\Projects\Subversion\subversion\bindings\swig\core.i(585): Error:
Unable to find 'svn_error_codes_h.swg'
c:\Projects\Subversion\subversion\bindings\swig\core.i(586): Error:
Unable to find 'svn_time_h.swg'
c:\Projects\Subversion\subversion\bindings\swig\core.i(587): Error:
Unable to find 'svn_types_h.swg'
c:\Projects\Subversion\subversion\bindings\swig\core.i(588): Error:
Unable to find 'svn_pools_h.swg'
c:\Projects\Subversion\subversion\bindings\swig\core.i(589): Error:
Unable to find 'svn_version_h.swg'
c:\Projects\Subversion\subversion\bindings\swig\core.i(595): Error:
Unable to find 'svn_props_h.swg'
c:\Projects\Subversion\subversion\bindings\swig\core.i(598): Error:
Unable to find 'svn_opt_h.swg'
c:\Projects\Subversion\subversion\bindings\swig\core.i(599): Error:
Unable to find 'svn_auth_h.swg'
c:\Projects\Subversion\subversion\bindings\swig\core.i(600): Error:
Unable to find 'svn_config_h.swg'
c:\Projects\Subversion\subversion\bindings\swig\core.i(601): Error:
Unable to find 'svn_utf_h.swg'
c:\Projects\Subversion\subversion\bindings\swig\core.i(602): Error:
Unable to find 'svn_nls_h.swg'
c:\Projects\Subversion\subversion\bindings\swig\core.i(603): Error:
Unable to find 'svn_path_h.swg'
c:\Projects\Subversion\subversion\bindings\swig\core.i(604): Error:
Unable to find 'svn_io_h.swg'
Project : error PRJ0019: A tool returned an error code from
"Performing Custom Build Step"
Project : warning PRJ0018 : The following environment variables were not found:
$(top_srcdir)

I thought I remembered a commit or something saying we'd dropped
support for older swigs.

DJ

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Thu Jul 13 14:20:41 2006

This is an archived mail posted to the Subversion Dev mailing list.