On Sun, 09 Jul 2006, Kamesh Jayachandran wrote:
> Had a tough time initially in understanding what 'elt2 & elt1' is
> 120 lines of while loop. Though my mind now can easily map what
> 'elt2 & elt1' is, it would have saved few minutes if names had been
> bit more hinting.
I agree that more descriptive and consistently named variable names
would improve the comprehensibility of this routine.
> Doc correction to function header 'parse_revlist'.
> * subversion/libsvn_subr/mergeinfo.c
> Doc header fix as follows,
> Typo fix 'revisioneelement' -> 'revisionelement',
> 'revisionrange | REVISION' -> 'revisionelement' in defining
Committed as r20485.
> Variable name change from 'elt1' to 'cur_wboard_range'
> 'elt2' to 'cur_erase_range'.
While I'm in favor of this type of change, I wonder if we shouldn't
remove the eraser/whiteboard metaphor at the same time, since it
simply isn't applicable to the "intersect" mode of this function.
Received on Sun Jul 9 01:20:43 2006
- application/pgp-signature attachment: stored