[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: VS2005 issues (was 1.4.0-rc1 tarballs up for testing/signing)

From: D.J. Heap <djheap_at_gmail.com>
Date: 2006-06-10 00:01:39 CEST

On 6/9/06, D.J. Heap <djheap@gmail.com> wrote:
> On 6/7/06, Jens Peters <jpeters7677@gmx.de> wrote:
> >
> > > Not really -- I know very little (as in nothing) about multilanguage
> > > stuff, but I'll try to take a closer look at this soon.
> > > Interestingly, I also get one svnlook test failure if I build with
> > > intl support that I do not get when I build without it. Not sure if
> > > it's related or not, but it's consistent.
> > >
> > The testsuite run fine with my build (expect some props related test,
> > but that is fixed in the testsuite as far as I know), local and
> > mod_dav_svn (if you disable SSPI :)), but this was svn 1.3.0. By the
> > way, I never tried to commit a file with an 'Umlaut' in its name of log
> > message. I guess later you would see the same garbled output as with the
> > translated string, but according to Stefan internally everything is
> > stored well. I'll test it when I'm at home again.
> >
>
> I've been debugging through this and the problem is that apr's iconv
> files (utf-8.so, etc) refuse to load ('module not found' error from
> LoadLibrary even though the path is correct). I'm guessing it has to
> do with the new C runtime manifest fun in VS2005, but I haven't
> figured it out yet and I'm out of time for now. Probably since the
> .so's are built differently, they aren't getting a manifest or
> something.
>

Actually, that was just the first problem. I do see the UTF-8 to
CP437 xlate take place successfully and then fputs is called and dumps
out ? instead of the special characters. I'll keep looking later, but
I'm not really sure what to look for. Is CP437 the wrong code page?

DJ

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Sat Jun 10 00:02:34 2006

This is an archived mail posted to the Subversion Dev mailing list.