[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Regarding 1.3.x/STATUS item for SWIG compat check

From: C. Michael Pilato <cmpilato_at_collab.net>
Date: 2006-05-19 17:11:27 CEST

Oh, and to add further confusion, I see *this* STATUS item:

  * r18924, r17931, r18928, r18951, r18953
    Support SWIG 1.3.28.
    Justification:
      The latest stable SWIG version is 1.3.28. To be used extensively,
      the Ruby bindings should support SWIG 1.3.28.
    Votes:
      +1: kou

Which seems to be less about making Subversion claim support for 1.3.28, and
more about making the Ruby bindings make use of 1.3.28's features, or somesuch.

Sheesh.

C. Michael Pilato wrote:
> I'm a little confused about this 1.3.x/STATUS item:
>
> * r17280, r18172, r18205, r18491
> Upgrade SWIG bindings to be compatible with SWIG 1.3.26-1.3.28
> Branch: 1.3.x-r17280
>
> So, we're trying to make the SWIG bindings compatible with SWIG 1.3.26 -
> 1.3.28, huh?
>
> Well, build/ac-macros/swig.m4 has this test:
>
> if test -n "$SWIG_VERSION" &&
> test "$SWIG_VERSION" -ge "103024" &&
> test "$SWIG_VERSION" -le "103028"; then
>
> Which seems to put the lower bound at 1.3.24, inclusive. But then, it also
> has this text:
>
> AC_MSG_WARN([Subversion requires 1.3.24 or later, and is known to work])
> AC_MSG_WARN([with versions up to 1.3.27])
>
> Which puts the upper bound at 1.3.27. But that's consistent with
> subversion/bindings/swig/INSTALL, which says:
>
> Step 1: Install a suitable version of SWIG (which is
> currently swig version 1.3.24 - 1.3.27).
>
> What *exactly* is the range of SWIG versions we're claiming support for
> here, folks?
>

-- 
C. Michael Pilato <cmpilato@collab.net>
CollabNet   <>   www.collab.net   <>   Distributed Development On Demand

Received on Fri May 19 17:13:19 2006

This is an archived mail posted to the Subversion Dev mailing list.