[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [PATCH]: Was [PROPOSAL] Takeover Take 2

From: Julian Foad <julianfoad_at_btopenworld.com>
Date: 2006-05-06 16:07:21 CEST

Philip Martin wrote:
>>+svn_error_t *svn_wc_get_update_editor3(svn_revnum_t *target_revision,
>>+ svn_wc_adm_access_t *anchor,
>>+ const char *target,
>>+ svn_boolean_t use_commit_times,
>>+ svn_boolean_t recurse,
>>+ svn_boolean_t forced_checkout,
>
> 'force' rather than 'forced_checkout' would be consistent with the
> other APIs, and is obviously better if it applies to updates as well.

If it might be applicable to updates as well as checkouts, then certainly a
name change is needed. However, use a specific term in APIs, not the vague
term "force", even if in our command-line client the option that currently
activates it is named "--force".

There shouldn't be more than about one API that uses the plain name "force", as
I instigated a clean-up of them about a year ago. One was left as "force"
because no better description could be found at the time. That's a sign that
the behaviour controlled by the flag was ill-defined.

> [I now think reusing "--force" was a mistake in the client, we should
> have used "--force xxx" or "--force-xxx" from the beginning.]

Agreed.

- Julian

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Sat May 6 16:07:48 2006

This is an archived mail posted to the Subversion Dev mailing list.