Daniel Rall wrote:
> On Thu, 27 Apr 2006, mhagger@tigris.org wrote:
> ...
>
>>--- trunk/subversion/tests/cmdline/svntest/testcase.py (original)
>>+++ trunk/subversion/tests/cmdline/svntest/testcase.py Thu Apr 27 16:27:18 2006
>>@@ -108,6 +108,10 @@
>> "A test that is expected to fail."
>>
>> def __init__(self, test_case, cond_func=lambda:1):
>>+ # We evaluate cond_func later because if we do it in __init__ it
>>+ # turns out that useful bits of information (like the fact that
>>+ # we're running over a particular RA layer) are not available.
>>+
>> TestCase.__init__(self)
>> self.test_case = create_test_case(test_case)
>> self._list_mode_text = self.test_case.list_mode() or 'XFAIL'
>
>
> Wouldn't this inline comment be more appropriate either next to the
> assignment of self.cond_func, or as a constructor doc string?
Thanks for the suggestion. I made the suggested change in 19469.
Michael
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Fri Apr 28 16:07:51 2006