[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: swig-pl trunk r17548: FAIL (x86_64-unknown-linux-gnu shared)

From: Jani Averbach <jaa_at_jaa.iki.fi>
Date: 2005-11-30 05:16:31 CET

On 2005-11-29 10:45-0800, Garrett Rooney wrote:
> On 11/28/05, svntest@jaa.iki.fi <svntest@jaa.iki.fi> wrote:
>
> > x86_64-pc-linux-gnu-gcc: core.o: No such file or directory
> > make[1]: *** [blib/arch/auto/SVN/_Core/_Core.so] Error 1
> > make[1]: Leaving directory `/svntest/obj-sh/subversion/bindings/swig/perl/native'
> > make: *** [swig-pl] Error 2
> > Complete log saved in /srv/svntest/svntest/logs/svn_trunk/LOG_swig-pl_build.failed
> > FAIL: swig-pl::build
>
> I'm having trouble reproducing this problem here, although granted,
> I'm not on x86_64 linux, has anyone else had any luck with it?

This seems to be build system / svntest setup bug:
The build system leaves behind autogenerated files which are not
regenerated when the source changes.

I will add a step to the test system which will clean up the working
copy a way that it will be 1:1 what you would get by clean
checkout. Also, we should check the build system of bindings and make
sure that it regenerates files when necessary.

BR, Jani

-- 
Jani Averbach
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Wed Nov 30 05:17:08 2005

This is an archived mail posted to the Subversion Dev mailing list.