[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: svn commit: r17544 - trunk/subversion/libsvn_fs_base

From: David James <james_at_cs.toronto.edu>
Date: 2005-11-28 20:40:20 CET

On 11/28/05, maxb@tigris.org <maxb@tigris.org> wrote:
> Log:
> Followup to r17496, r17501.
> Kill more APR-0.9.4-and-earlier compatibility code.
> [...]
> -/* Ensure compatibility with older APR 0.9.5 snapshots which don't
> - * support the APR_LARGEFILE flag. */
> -#ifndef APR_LARGEFILE
> -#define APR_LARGEFILE (0)
> -#endif
> -
Max,

According to the comment above, it looks like this compatibility code
is necessary for development snapshots of 0.9.5, which (I assume)
shipped with some versions of Apache 2.0.x, prior to the official
0.9.5 release. Your log message, on the other hand, states that you're
removing 0.9.4-and-earlier compatibility code. Which is correct?

Cheers,

David

--
David James -- http://www.cs.toronto.edu/~james
Received on Mon Nov 28 21:27:53 2005

This is an archived mail posted to the Subversion Dev mailing list.