[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [PATCH] Issue #2419: 'svn rm' of schedule add leaves working props file V2

From: Madan U Sreenivasan <madan_at_collab.net>
Date: 2005-11-09 03:25:37 CET

Hi All,
  Could some committer please review the aforesent patch. Thank you.

Regards,
Madan.

On Tue, 2005-11-08 at 02:33, Madan U Sreenivasan wrote:
> Hi David, Barry and dionisos,
>
> I have tried to fix the problems David has suggested. Have also used
> Barry's suggestions(Thx Barry, skipping the + is really cool).
>
> I see that dionisos has committed my older patch at r17216 and
> r17217.
>
> So, heres a correction to the existing codebase, that fixes the
> problems discussed earlier, makes the test more robust and uses
> dionisos's idea of using svn_wc__loggy_remove() for file removal.
>
> HTH,
> Regards,
> Madan.
>
>
> On Sat, 2005-11-05 at 07:49, David James wrote:
> > On 11/4/05, Madan U Sreenivasan <madan@collab.net> wrote:
> > > Hi,
> > > Pl. find attached the patch with the changes suggested for the test.
> > Hi Madan,
> >
> > Your patch generally looks good. I have a few style suggestions, but
> > these can be fixed when we commit the patch.
> >
> > > + if (was_schedule == svn_wc_schedule_add)
> > > + {
> > > + /* remove the properties file */
> > > + const char *svn_thang;
> > svn_thang? What's that? Can you pick a better name for this variable?
> > Perhaps "properties_filename"?
> >
> > > + /* Working prop file. */
> > Might it be better if this comment said "remove the properties file"
> > instead? Then we can remove the first (misplaced) comment which says
> > "remove the properties file" in front of our declaration of svn_thang.
> >
> > > [...]
> > > + file_add_output = "A svn-test-work/working_copies/"
> > > + file_add_output = file_add_output + "prop_tests-16/newfile"
> > > + propset_output = "property 'newprop' set on 'svn-test-work/"
> > > + propset_output = propset_output + "working_copies/prop_tests-16/newfile"
> > In Python, if a string doesn't fit on one line, we usually construct
> > strings like this:
> > file_add_output = ("A svn-test-work/working_copies/"
> > + "prop_tests-16/newfile")
> >
> > Cheers,
> >
> > David
> >
> > --
> > David James -- http://www.cs.toronto.edu/~james
>
> ______________________________________________________________________
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
> For additional commands, e-mail: dev-help@subversion.tigris.org

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Wed Nov 9 03:17:14 2005

This is an archived mail posted to the Subversion Dev mailing list.