[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: svn log --limit 100 gives "200 OK" error with 1.3.x

From: Garrett Rooney <rooneg_at_electricjellyfish.net>
Date: 2005-10-26 21:40:08 CEST

On 26 Oct 2005 12:49:18 -0500, kfogel@collab.net <kfogel@collab.net> wrote:
> Garrett Rooney <rooneg@electricjellyfish.net> writes:
> > It looks like our 'svn log --limit' compatibility code for old
> > servers) wasn't working quite right with new versions of neon (I think
> > that's what was happening anyway, since I couldn't seem to reproduce
> > it with an older version of neon). I've made the code a bit more
> > robust (see revision 17037), and that seems to fix the problem for me.
> >
> > I'll see about getting this into a 1.3.x release.
>
> This is shameless of me to say, since I won't have time to do it
> myself (today, at least), but: wouldn't a regression test for this be
> nice? We got lucky only because Stefan happened to run into it...

This bug only occurs when you run a current client against an old
server, so a regression test wouldn't have caught it. I do agree
though, tests for this feature would be good to have.

-garrett

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Wed Oct 26 21:41:32 2005

This is an archived mail posted to the Subversion Dev mailing list.