[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: swig-rb trunk r16724: FAIL (x86_64-unknown-linux-gnu shared)

From: Erik Huelsmann <ehuels_at_gmail.com>
Date: 2005-10-16 00:44:55 CEST

On 10/16/05, David James <james82@gmail.com> wrote:
> On 10/15/05, svntest@jaa.iki.fi <svntest@jaa.iki.fi> wrote:
> > swig-rb: trunk r16724 on x86_64-unknown-linux-gnu shared
> > TIME: 2005-10-15 02:19:11 -0600
> >
> > PASS: swig-rb::check build type
> >
> > /srv/svntest/svntest/config.shared:
> > #!/bin/sh
> > # /srv/svntest/svntest/config.shared
> > #
> > "/srv/svntest/svntest/svn/svn_trunk/configure" \
> > "--prefix=/srv/svntest/svntest/inst/svn_trunk" \
> > "--with-apr=/srv/svntest/svntest/inst/apr-0.9.x/bin/apr-config" \
> > "--with-apr-util=/srv/svntest/svntest/inst/apu-0.9.x-db43/bin/apu-config" \
> > "--with-apxs=/srv/svntest/svntest/inst/httpd-2.0.x/bin/apxs" \
> > "--with-pic" \
> > "--with-swig" \
> > "--enable-javahl" \
> > "--with-junit=/opt/junit/3.8.1/junit.jar" \
> > "$@"
> >
> > PASS: swig-rb::build
> >
> > Last 100 lines of the log file follow:
> > cd /srv/svntest/svntest/obj-sh/subversion/bindings/swig/ruby; \
> > /usr/bin/ruby -I /srv/svntest/svntest/svn/svn_trunk/subversion/bindings/swig/ruby \
> > /srv/svntest/svntest/svn/svn_trunk/subversion/bindings/swig/ruby/test/run-test.rb \
> > --verbose=normal
> > Loaded suite test
> > Started
> > .....................FF....F................................................................................E..........
> > Finished in 297.127981 seconds.
> > 1) Failure:
> > test_merge(SvnClientTest) [/srv/svntest/svntest/svn/svn_trunk/subversion/bindings/swig/ruby/test/test_client.rb:701]:
> > <false> is not true.
> >
> > 2) Failure:
> > test_merge_peg(SvnClientTest) [/srv/svntest/svntest/svn/svn_trunk/subversion/bindings/swig/ruby/test/test_client.rb:748]:
> > <false> is not true.
> It looks like these failures were caused by the wc-replacements branch merge.
>
> Here's a test case:
> rm -rf repo wc
> svnadmin create repo
> svn co file://`pwd`/repo wc
> cd wc
> touch sample.txt
> svn add sample.txt
> svn commit -m ""
> svn rm sample.txt
> svn revert sample.txt
> svn commit -m ""
>
> After running the above commands, we delete sample.txt (even though we
> reverted the delete).
>
> > 3) Failure:
> > test_move_force(SvnClientTest) [/srv/svntest/svntest/svn/svn_trunk/subversion/bindings/swig/ruby/test/test_client.rb:964]:
> > <["/svntest/obj-sh/subversion/bindings/swig/ruby/test/wc/sample2.txt",
> > "test/wc/sample1.txt",
> > "test/wc/sample2.txt"]> expected but was
> > <["test/wc/sample1.txt", "test/wc/sample2.txt"]>.
> Anyone know what causes this problem?
>
> > 4) Error:
> > test_adm_access(SvnWcTest):
> > Svn::Error::WC_BAD_ADM_LOG: /srv/svntest/svntest/svn/svn_trunk/subversion/libsvn_wc/log.c:346 In directory 'test/wc/dir'
> > Error processing command 'set-timestamp' in 'test/wc/dir'
> > Missing 'timestamp' attribute in 'test/wc/dir'
> > /srv/svntest/svntest/svn/svn_trunk/subversion/bindings/swig/ruby/svn/util.rb:58:in `svn_wc_revert2'
> > /srv/svntest/svntest/svn/svn_trunk/subversion/bindings/swig/ruby/svn/util.rb:58:in `revert2'
> > /srv/svntest/svntest/svn/svn_trunk/subversion/bindings/swig/ruby/svn/wc.rb:333:in `revert'
> > /srv/svntest/svntest/svn/svn_trunk/subversion/bindings/swig/ruby/test/test_wc.rb:109:in `test_adm_access'
>
> This looks like it's related to the bug in revert.

Does r16740 fix the problem?

bye,

Erik.
Received on Sun Oct 16 00:45:40 2005

This is an archived mail posted to the Subversion Dev mailing list.