[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: svn commit: r16652 - trunk/subversion/include

From: Julian Foad <julianfoad_at_btopenworld.com>
Date: 2005-10-12 16:54:26 CEST

C. Michael Pilato wrote:
> So, I'd like to see:
> - s/svn_opt_revision_value/svn_opt__revision_value_t/ (we can
> "publicize" it when we really need to).

I can't see much reason to make it public, nor much reason to make it private.
  In that case it should be private, because that gives us more flexibility in
the future.

On the other hand, trying to make a part of a public structure private is
probably not going to work very well in a vague hand-waving whole-experience
way. Like giving a bit of extra hassle to SWIG maintainers and other such
tools: they may run into problems if they try to say "this tool should ignore
double-underscore symbols".

I don't know. In general I think we should avoid making too many things
public, but I think we've gone way beyond the stage where one more makes any
difference. (In other words, our APIs have much bigger over-exposure problems
than this.)

So I'd mildly suggest leaving it public.

> - the definition be like "typedef union svn_opt... { } svn_opt...;"


I think it's time to just do it now, whichever way you finally feel like.

- Julian

To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Wed Oct 12 16:55:29 2005

This is an archived mail posted to the Subversion Dev mailing list.

This site is subject to the Apache Privacy Policy and the Apache Public Forum Archive Policy.