[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [PATCH] Issue 443 : post-commit hook (error) output lost: Step 5

From: David James <james82_at_gmail.com>
Date: 2005-10-10 17:29:36 CEST

On 10/10/05, Madan U Sreenivasan <madan@collab.net> wrote:
> > - Rename this function to "svn_commit_info_dup"
> np.
> /me wonders if theres a naming convention that I have missed reading
> about...
There's no official conventions for writing "deep copy" functions, but
I'd like to make some: If a type is named "svn_foo_bar_t", the "deep
copy" function should be called "svn_foo_bar_dup". Further, all deep
copy functions should normally return the new object as a pointer, and
accept the following two arguments:
1. A const pointer to the object you want to copy (e.g. const svn_foo_bar_t *)
2. The pool to use to make the deep copy

These conventions make it easier for us to automatically generate code
that uses the deep copy functions in the SWIG bindings. See r16398 for
an example. Maybe we should document this in hacking.html?

Cheers,

David

--
David James -- http://www.cs.toronto.edu/~james
Received on Mon Oct 10 17:30:49 2005

This is an archived mail posted to the Subversion Dev mailing list.

This site is subject to the Apache Privacy Policy and the Apache Public Forum Archive Policy.