[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Use of word "force" propagated too deeply on locking implementation

From: Peter N. Lundblad <peter_at_famlundblad.se>
Date: 2005-08-24 20:10:58 CEST

On Wed, 24 Aug 2005, Greg Hudson wrote:

> When Peter added locking support to ra_svn, he used the keyword
> "force" to refer to the steal_lock and break_lock flags for lock and
> unlock respectively.
If I need to defend myself, the parameter to svn_fs_lock/unlock was also
called force at the time I did this...

> "Force" is a UI concept. It has no place in a network protocol. To
> those who implemented locking, please change the names of those fields
> to break-lock and steal-lock in the protocol description, and the
> variable names used in svnserve to break_lock and steal_lock.
> The word "force" should also not be used in the svn_ra layer, as that
> is not specific to the command-line UI. Those parameter names should
> be changed.
These are good ideas. Adding to my TODO list.


To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Wed Aug 24 20:11:47 2005

This is an archived mail posted to the Subversion Dev mailing list.

This site is subject to the Apache Privacy Policy and the Apache Public Forum Archive Policy.