[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Issue 2016 fixed incompletely

From: Ivan Zhakov <chemodax_at_gmail.com>
Date: 2005-06-30 18:02:18 CEST

Environment: Windows XP Professional, Subversion 1.2.0
It seems that issue 2016
(http://subversion.tigris.org/issues/show_bug.cgi?id=2016) fixed
incompletley. There is debug log for executing command "svn st":
'svn.exe': Loaded 'C:\Program Files\Subversion\bin\svn.exe', No symbols loaded.
'svn.exe': Loaded 'C:\WINDOWS\system32\ntdll.dll', No symbols loaded.
'svn.exe': Loaded 'C:\WINDOWS\system32\kernel32.dll', No symbols loaded.
'svn.exe': Loaded 'C:\Program Files\Subversion\bin\intl3_svn.dll', No
symbols loaded.
'svn.exe': Loaded 'C:\WINDOWS\system32\msvcrt.dll', No symbols loaded.
'svn.exe': Loaded 'C:\Program Files\Subversion\bin\libapr.dll', No
symbols loaded.
'svn.exe': Loaded 'C:\WINDOWS\system32\advapi32.dll', No symbols loaded.
'svn.exe': Loaded 'C:\WINDOWS\system32\rpcrt4.dll', No symbols loaded.
'svn.exe': Loaded 'C:\WINDOWS\system32\ws2_32.dll', No symbols loaded.
'svn.exe': Loaded 'C:\WINDOWS\system32\ws2help.dll', No symbols loaded.
'svn.exe': Loaded 'C:\WINDOWS\system32\mswsock.dll', No symbols loaded.
'svn.exe': Loaded 'C:\Program Files\Subversion\bin\libeay32.dll', No
symbols loaded.
'svn.exe': Loaded 'C:\WINDOWS\system32\wsock32.dll', No symbols loaded.
'svn.exe': Loaded 'C:\WINDOWS\system32\gdi32.dll', No symbols loaded.
'svn.exe': Loaded 'C:\WINDOWS\system32\user32.dll', No symbols loaded.
'svn.exe': Loaded 'C:\Program Files\Subversion\bin\ssleay32.dll', No
symbols loaded.
'svn.exe': Loaded 'C:\WINDOWS\system32\shfolder.dll', No symbols loaded.
'svn.exe': Loaded 'C:\Program Files\Subversion\bin\libaprutil.dll', No
symbols loaded.
'svn.exe': Loaded 'C:\Program Files\Subversion\bin\libdb43.dll', No
symbols loaded.
'svn.exe': Loaded 'C:\WINDOWS\system32\msvcp60.dll', No symbols loaded.
'svn.exe': Loaded 'C:\Program Files\Subversion\bin\libapriconv.dll',
No symbols loaded.
'svn.exe': Loaded 'C:\WINDOWS\system32\shell32.dll', No symbols loaded.
'svn.exe': Loaded 'C:\WINDOWS\system32\shlwapi.dll', No symbols loaded.
'svn.exe': Loaded
'C:\WINDOWS\WinSxS\x86_Microsoft.Windows.Common-Controls_6595b64144ccf1df_6.0.2600.2180_x-ww_a84f1ff9\comctl32.dll',
No symbols loaded.
'svn.exe': Loaded 'C:\WINDOWS\system32\comctl32.dll', No symbols loaded.
'svn.exe': Unloaded 'C:\WINDOWS\system32\shell32.dll'
'svn.exe': Loaded 'C:\WINDOWS\system32\shell32.dll', No symbols loaded.
'svn.exe': Unloaded 'C:\WINDOWS\system32\shell32.dll'
'svn.exe': Loaded 'C:\WINDOWS\system32\shell32.dll', No symbols loaded.
'svn.exe': Unloaded 'C:\WINDOWS\system32\shell32.dll'
'svn.exe': Loaded 'C:\WINDOWS\system32\shell32.dll', No symbols loaded.
'svn.exe': Unloaded 'C:\WINDOWS\system32\shell32.dll'
'svn.exe': Loaded 'C:\WINDOWS\system32\shell32.dll', No symbols loaded.
'svn.exe': Unloaded 'C:\WINDOWS\system32\shell32.dll'
'svn.exe': Loaded 'C:\Program Files\Subversion\iconv\windows-1251.so',
No symbols loaded.
'svn.exe': Unloaded 'C:\Program Files\Subversion\iconv\windows-1251.so'
'svn.exe': Loaded 'C:\Program Files\Subversion\iconv\_tbl_simple.so',
No symbols loaded.
'svn.exe': Loaded 'C:\Program Files\Subversion\iconv\windows-1251.so',
No symbols loaded.
'svn.exe': Loaded 'C:\Program Files\Subversion\iconv\utf-8.so', No
symbols loaded.
'svn.exe': Unloaded 'C:\Program Files\Subversion\iconv\windows-1251.so'
'svn.exe': Unloaded 'C:\Program Files\Subversion\iconv\_tbl_simple.so'
'svn.exe': Unloaded 'C:\Program Files\Subversion\iconv\utf-8.so'
'svn.exe': Loaded 'C:\Program Files\Subversion\iconv\windows-1251.so',
No symbols loaded.
'svn.exe': Unloaded 'C:\Program Files\Subversion\iconv\windows-1251.so'
'svn.exe': Loaded 'C:\Program Files\Subversion\iconv\_tbl_simple.so',
No symbols loaded.
'svn.exe': Loaded 'C:\Program Files\Subversion\iconv\windows-1251.so',
No symbols loaded.
'svn.exe': Loaded 'C:\Program Files\Subversion\iconv\utf-8.so', No
symbols loaded.
'svn.exe': Loaded 'C:\Program Files\Subversion\iconv\cp866.so', No
symbols loaded.
'svn.exe': Unloaded 'C:\Program Files\Subversion\iconv\cp866.so'
'svn.exe': Loaded 'C:\Program Files\Subversion\iconv\cp866.so', No
symbols loaded.
'svn.exe': Unloaded 'C:\Program Files\Subversion\iconv\cp866.so'
'svn.exe': Loaded 'C:\Program Files\Subversion\iconv\cp866.so', No
symbols loaded.
'svn.exe': Unloaded 'C:\Program Files\Subversion\iconv\cp866.so'
'svn.exe': Loaded 'C:\Program Files\Subversion\iconv\cp866.so', No
symbols loaded.
'svn.exe': Loaded 'C:\WINDOWS\system32\ntmarta.dll', No symbols loaded.
'svn.exe': Loaded 'C:\WINDOWS\system32\wldap32.dll', No symbols loaded.
'svn.exe': Loaded 'C:\WINDOWS\system32\ole32.dll', No symbols loaded.
'svn.exe': Loaded 'C:\WINDOWS\system32\samlib.dll', No symbols loaded.
'svn.exe': Unloaded 'C:\Program Files\Subversion\iconv\cp866.so'
'svn.exe': Unloaded 'C:\Program Files\Subversion\iconv\windows-1251.so'
'svn.exe': Unloaded 'C:\Program Files\Subversion\iconv\_tbl_simple.so'
'svn.exe': Unloaded 'C:\Program Files\Subversion\iconv\utf-8.so'
The program '[3852] svn.exe: Native' has exited with code 0 (0x0).

As you can see that module:
 * shell32.dll loaded/unloaded 5 times
 * windows-1251.so loaded/unloaded 3 times
 * cp866.so loaded/unloaded 4 times

May be it is not great performance regression, but still a bug.
 

-- 
Ivan Zhakov
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Thu Jun 30 19:32:20 2005

This is an archived mail posted to the Subversion Dev mailing list.