[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Available ports and the Subversion/Ruby test suite

From: David James <james82_at_gmail.com>
Date: 2005-06-17 06:07:16 CEST

On 6/16/05, Jani Averbach <jaa@jaa.iki.fi> wrote:
> I integrated David's svntest patches to my svntest setup, so
> ruby bindings will be tested every night (around 21:20 (-0700)).
>
> Now I get the following error:
>
> cd /srv/svntest/svntest/obj-sh/subversion/bindings/swig/ruby; \
> /usr/bin/ruby -I /srv/svntest/svntest/svn/svn_trunk/subversion/bindings/swig/ruby \
> /srv/svntest/svntest/svn/svn_trunk/subversion/bindings/swig/ruby/test/run-test.rb
> /srv/svntest/svntest/svn/svn_trunk/subversion/bindings/swig/ruby/svn/error.rb:1:in `require': no such file to load --
> +svn/ext/core (LoadError)
> from /srv/svntest/svntest/svn/svn_trunk/subversion/bindings/swig/ruby/svn/error.rb:1
> from /srv/svntest/svntest/svn/svn_trunk/subversion/bindings/swig/ruby/svn/client.rb:2:in `require'
> from /srv/svntest/svntest/svn/svn_trunk/subversion/bindings/swig/ruby/svn/client.rb:2
> from /srv/svntest/svntest/svn/svn_trunk/subversion/bindings/swig/ruby/test/util.rb:3:in `require'
> from /srv/svntest/svntest/svn/svn_trunk/subversion/bindings/swig/ruby/test/util.rb:3
> from /srv/svntest/svntest/svn/svn_trunk/subversion/bindings/swig/ruby/test/test_client.rb:2:in `require'
> from /srv/svntest/svntest/svn/svn_trunk/subversion/bindings/swig/ruby/test/test_client.rb:2
> from /usr/lib64/ruby/1.8/test/unit/collector/dir.rb:83:in `require'
> ... 6 levels...
> from /usr/lib64/ruby/1.8/test/unit/autorunner.rb:61:in `[]'
> from /usr/lib64/ruby/1.8/test/unit/autorunner.rb:198:in `run'
> from /usr/lib64/ruby/1.8/test/unit/autorunner.rb:13:in `run'
> from /srv/svntest/svntest/svn/svn_trunk/subversion/bindings/swig/ruby/test/run-test.rb:17
> make: *** [check-swig-rb] Error 1
> Complete log saved in /srv/svntest/svntest/logs/svn_trunk/LOG_swig-rb_check.failed
> FAIL: swig-rb::check
>
> The ruby is:
> $ ruby --version
> ruby 1.8.3 (2005-05-12) [x86_64-linux]
FYI, the test suite works with Ruby 1.8.2. So this problem is probably
also caused by the API changes in Ruby 1.8.3.

Cheers,

David

-- 
David James -- http://www.cs.toronto.edu/~james
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Fri Jun 17 06:08:07 2005

This is an archived mail posted to the Subversion Dev mailing list.