[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: issue with svn 1.2.0 client against 1.1.x server

From: C. Michael Pilato <cmpilato_at_collab.net>
Date: 2005-06-06 22:51:51 CEST

Hmm... I saw similar behavior the other day, but assumed it was some sort of
fluke.

"Michael S. Tsirkin" <mst@mellanox.co.il> writes:

> Hello!
> With subversion client version 1.2.0
>
> >time /usr/local/svn12/bin/svn list https://openib.org/svn
> branches/
> gen1/
> gen2/
> tags/
> trunk/
> 0.395u 0.067s 1:53.62 0.3% 0+0k 0+0io 0pf+0w
>
> While with client 1.1.4 against the same server I have:
>
> >time svn list https://openib.org/svn
> branches/
> gen1/
> gen2/
> tags/
> trunk/
> 0.019u 0.007s 0:04.29 0.2% 0+0k 0+0io 11pf+0w
>
> So subversion 1.2.0 is taking 2 minutes where 1.1.4 takes 4 seconds
> to contact the same remote repository.
>
> This observation was independently confirmed by another svn user.
> Running strace on versions 1.2.0 and 1.1.4, I see that subversion 1.2.0
> does around 17000 system calls, while 1.1.4 only around 750.
> Further, most of the time while client 1.2.0 appears stuck,
> it is actually performing read/write/select calls, presumably from the socket.
>
> Both clients are built from source with ./configure --prefix=xxxxx --with-ssl
> The openib.org server is AFAIK 1.1.x
>
> This problem prevents me from changing my client to 1.2.0.
> Is this a known issue?
>
> Thanks,
> --
> MST
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
> For additional commands, e-mail: dev-help@subversion.tigris.org

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Mon Jun 6 22:54:12 2005

This is an archived mail posted to the Subversion Dev mailing list.