[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: svn hangs in certain directories

From: David Summers <david_at_summersoft.fay.ar.us>
Date: 2005-05-25 07:01:20 CEST

I have also seen this behaviour, but I've not been able to
classify/predict when it will happen. It happened 10+ times a week or so
ago but I've not seen it since.

    - David

On Wed, 25 May 2005, Colin JN Breame wrote:

> I've recently upgraded to version 1.1.4 and i'm having a few problems.
>
> Everything is ok when I do:
> $ svn ls svn://my_host/
>
> But when I do:
> $ svn ls svn://my_host/directory_with_a_file_in
>
> svn hangs. This only appears to happen in directories with files in. e.g.
> everything is ok when listing directories that only contain directories.
> Other functions are affected (including checkout).
>
> The server is windows based and is using svnserve. No authenication is used.
> The client is linux based. Both server and client are using 1.1.4.
>
> The hang appears to result from an indefinite block when reading from the
> server (ra_svn_get_file). As the server never returns a response. Maybe
> there should be a timeout condition rather than just hanging...
>
> I've attached the communications between client and server. Before i ran the
> commands I used svnadmin recover on the repository.
>
> Any ideas?
>
> -- Colin
>

--
David Wayne Summers        "Linux: Because reboots are for hardware upgrades!"
david_at_summersoft.fay.ar.us PGP Key: http://summersoft.fay.ar.us/~david/pgp.txt
PGP Key fingerprint =  0B44 B118 85CC F4EC 7021  1ED4 1516 5B78 E320 2001
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Wed May 25 07:02:04 2005

This is an archived mail posted to the Subversion Dev mailing list.